for desktop applications

Latest Glimpse Framework release: 0.4

Minimum Kotlin version: 1.0.4

Desktop applications require following dependencies:

Minimum Gradle configuration

buildscript {
	ext.kotlin_version = '1.0.4'
	ext.glimpse_version = '0.4'

	repositories {
		jcenter()
	}

	dependencies {
		classpath "org.jetbrains.kotlin:kotlin-gradle-plugin:${kotlin_version}"
	}
}

apply plugin: 'kotlin'

repositories {
	jcenter()
}

dependencies {
	compile "org.glimpseframework:glimpse-framework-api:${glimpse_version}"
	compile "org.glimpseframework:glimpse-framework-jogl:${glimpse_version}"
	compile "org.glimpseframework:glimpse-framework-materials:${glimpse_version}"
}